Delayed Cosmos Withdrawals
Incident Report for Coinbase Prime
Resolved
This incident has been resolved.
Posted Dec 07, 2020 - 13:27 PST
Investigating
We are currently investigating the issue.
Posted Dec 07, 2020 - 12:57 PST