Delayed withdrawals on AVAX (Avalanche)
Incident Report for Coinbase Prime
Resolved
This incident has been resolved.
Posted Nov 22, 2021 - 23:06 UTC
Investigating
We are currently investigating this issue.
Posted Nov 22, 2021 - 19:56 UTC