Delayed Filecoin (FIL) withdrawals
Incident Report for Coinbase Prime
Resolved
This incident has been resolved.
Posted Mar 02, 2022 - 21:59 UTC
Investigating
We are currently investigating this issue.
Posted Mar 02, 2022 - 21:21 UTC