Investigating delays with ETC Deposits and Withdrawals
Incident Report for Coinbase Prime
Resolved
This incident has been resolved.
Posted Jan 20, 2021 - 20:17 PST
Investigating
We are currently investigating this issue.
Posted Jan 20, 2021 - 18:54 PST
This incident affected: Transfers (Ethereum Classic Network).