Delayed Deposits / Withdrawals on EOSIO (EOS)
Incident Report for Coinbase Prime
Resolved
This incident has been resolved.
Posted Apr 28, 2022 - 22:18 UTC
Investigating
We are currently investigating this issue.
Posted Apr 28, 2022 - 18:59 UTC