Delayed Deposits / Withdrawals on Cosmos (ATOM)
Incident Report for Coinbase Prime
Resolved
This incident has been resolved.
Posted Apr 13, 2022 - 05:23 UTC
Investigating
We are currently investigating this issue.
Posted Apr 11, 2022 - 18:39 UTC