Delayed transactions Bitcoin (BTC)
Incident Report for Coinbase Prime
Resolved
This incident has been resolved.
Posted May 17, 2023 - 16:53 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted May 17, 2023 - 16:46 UTC
Investigating
BTC deposits and withdrawals are currently delayed due to a technical issue. Funds are safe while our teams are working to resolve ASAP.
Posted May 17, 2023 - 15:37 UTC