Polkadot Sends and Receives Delayed
Incident Report for Coinbase Prime
Resolved
This incident has been resolved.
Posted Oct 18, 2022 - 11:37 UTC
Investigating
We are currently investigating this issue.
Posted Oct 18, 2022 - 11:25 UTC