Delayed Transactions (DOGE)
Incident Report for Coinbase Prime
Resolved
This incident has been resolved.
Posted Nov 28, 2023 - 20:21 UTC
Investigating
Sends/receives are delayed for Dogecoin (DOGE). While we work on a fix, your funds remain secure.
Posted Nov 28, 2023 - 06:35 UTC