Delayed Transactions (SUI)
Incident Report for Coinbase Prime
Resolved
This incident has been resolved.
Posted Dec 04, 2023 - 02:17 UTC
Investigating
Sends/receives are delayed for SUI (SUI). While we work on a fix, your funds remain secure.
Posted Dec 03, 2023 - 05:39 UTC