Delayed Transactions (CGLD)
Incident Report for Coinbase Prime
Resolved
This incident has been resolved.
Posted Mar 17, 2023 - 05:47 UTC
Investigating
Sends/receives are delayed for Celo (CGLD). While we work on a fix, your funds remain secure.
Posted Mar 17, 2023 - 04:58 UTC