Delayed Cosmos (ATOM) Deposits and Withdrawals
Incident Report for Coinbase Prime
Resolved
This incident has been resolved.
Posted Jun 16, 2022 - 19:02 UTC
Investigating
We are currently investigating this issue.
Posted Jun 16, 2022 - 15:52 UTC