ADA sends and receives delayed.
Incident Report for Coinbase Prime
Resolved
This incident has been resolved.
Posted Sep 17, 2022 - 03:47 UTC
Investigating
We are currently investigating this issue.
Posted Sep 16, 2022 - 23:26 UTC