Delayed Transactions (FIL)
Incident Report for Coinbase Prime
Resolved
This incident has been resolved.
Posted Apr 30, 2023 - 18:32 UTC
Investigating
Sends/receives are delayed for Filecoin (FIL). While we work on a fix, your funds remain secure.
Posted Apr 27, 2023 - 13:51 UTC