Delayed transactions (XLM)
Incident Report for Coinbase Prime
Resolved
This incident has been resolved.
Posted Apr 18, 2023 - 07:38 UTC
Investigating
Sends are delayed for Stellar Lumens (XLM). While we work on a fix, your funds remain secure.
Posted Apr 17, 2023 - 15:41 UTC