Kusama Sends and Receives Delayed
Incident Report for Coinbase Prime
Resolved
This incident has been resolved.
Posted Nov 21, 2022 - 22:21 UTC
Investigating
We are currently investigating this issue.
Posted Nov 21, 2022 - 15:32 UTC